Upgrade To The Latest FFmpeg and x264 in Ubuntu Intrepid and Jaunty

A while ago I posted some fixed ffmpeg and x264 packages for Ubuntu Jaunty (.deb) but you may want to upgrade to the latest version of ffmpeg and x264 (whichever the latest version is). So this how-to will explain how to install the latest FFmpeg and x264 and then how to always update those packages. Read on!