Ubuntu security notice - kernel vulnerabilities found in all supported releases

There’s an important security notice from the Ubuntu folks.  A kernel vulnerability was found.  It’s pretty much only vulnerable to local attacks but it’s always a good idea to update your boxes to the latest versions of the kernel (as noted in the below announcement) so that you reduce your vulnerability to threats.

Here’s the announcement.

=========================================================== Ubuntu Security Notice USN-637-1 August 25, 2008 linux, linux-source-2.6.15/20/22 vulnerabilities CVE-2008-2812, CVE-2008-2931, CVE-2008-3272, CVE-2008-3275 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 7.04 Ubuntu 7.10 Ubuntu 8.04 LTS This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu.

The problem can be corrected by upgrading your system to the following package versions: