Firefox 3 beta 5 reached Hardy’s repositories

Ubuntu users, Firefox 3 beta 5 (3b5) has reached Hardy’s repositories. Gutsy (and older versions) users, enable Hardy repo’s to upgrade it.

To be able to install the extensions that are not supported by this version of firefox (since the new addons website interface which sucks by the way), here’s what you must do to bypass it:

http://icehot.wordpress.com/2008/04/05/firefox-3-beta-5-reached-hardys-repositories/