Fglrx Finally Works With Ubuntu 10.10 (Xorg 1.9, Kernel 2.6.35/36)

Fglrx was updated yesterday in Ubuntu 10.10 Maverick Meerkat and what's special about this is that it finally supports Xorg 1.9 and 2.6.35 kernel. Up until now, ATI users who've tried to install Fglrx or upgraded from Ubuntu 10.04 would get a blank screen. So if you have an ATI graphics card and want to use Fglrx, you can finally install / upgrade to the latest Ubuntu 10.10.